Board index » America's Army: Proving Grounds » AA:PG Server Support




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 
Author Message
 Post subject: Auth Issues
 Post Posted: Fri Feb 20, 2015 12:48 am 
Offline

Joined: Fri Feb 20, 2015 12:34 am
Posts: 3
I run a GSP, we've been trailing the game for some time with players however always running into auth issues.

There's no firewall or anything running on these servers, these servers also have public IPs.

We've noticed that we can launch games manually with the 'launcher', these register and work without an issue. We can then launch the games with the game panel. After 3-4 days, if the server is restarted via the game panel, we get an MASS error about non-authentication.

To fix the issue we just launch the server with the launcher, stop it, then launch it with the game panel. It's like there's an auth cache of 3-4 days and it seems the way we're launching servers, they don't auth.

The only difference I can think of is the /CONFIGSUBDIR which the launcher always tries to use. I've ensured that the AAPG\Binaries\MASAuthOptions.ini is generated on start each time, this seems to be what happens when I use a file mod watcher on the game dir when using the launcher.

The cmd line looks like:
AAPG\Binaries\Win32\AAGame.exe server BDX_Breach_EX /GLOBAL MaxPlayers=24 MULTIHOME=203.33.121.182 /STEAMSERVERIP=203.33.121.182 /AuthServerIP=203.33.121.182 /SGSP=7778 /AuthServerUserName=****** /AuthServerPassword=***** AdminPassword=****** /NOPAUSE /NOHOMEDIR

I've even tried some packet capturing to determine if there's some special type of curl or tcp connection sent via the launcher which we're not however I'm really not able to find anything.

We did need to put the Steam SDK .dll's in the root dir of the game ie: where the AAPG folder exists and the Steam cache dir to make PB etc work correctly.

Logs look like (sanitised)

Code:
Init: Command line: server BDX_Breach_EX /GLOBAL /AuthServerUserName=***** /AuthServerPassword=***** /AuthServerIP=203.33.121.182 /STEAMSERVERIP=203.33.121.182 MaxPlayers=24 MULTIHOME=203.33.121.182 /SGSP=7778 AdminPassword=***** /NOPAUSE /NOHOMEDIR
Init: Base directory: D:\gsp-panel\users\gsp_156\203.33.121.182-7778\AAPG\Binaries\Win32\
[0007.52] Log: Bringing World BDX_Breach_EX.TheWorld up for play (30) at 2015.02.20-15.31.54
[0007.52] ScriptLog: AccessControl: Trying to register authentication delegates with an online subsystem that does not support authentication
[0007.52] ScriptLog: (AAGameVeteran_0) AAGameInfo::AAGameVeteran:RegisterServer AAGameSettingsCommon OnlineSubsystemAAPC_0 OnlineGameInterfaceImpl_0
[0007.52] ScriptWarning: Failed to register game with online service. Registering as a LAN match
   AAGameVeteran BDX_Breach_EX.TheWorld:PersistentLevel.AAGameVeteran_0
   Function Engine.GameInfo:OnServerCreateComplete:010A
[0007.52] Error: Can't create a new online session when one is in progress: Transient.AAGameSettingsCommon_0
[0007.52] ScriptWarning: Failed to register game with online service. Game won't be advertised
   AAGameVeteran BDX_Breach_EX.TheWorld:PersistentLevel.AAGameVeteran_0
   Function Engine.GameInfo:OnServerCreateComplete:0212
[0007.53] Log: Updated Destroyable List:  0
[0007.53] ScriptLog: Server Steam authentication or LAN MBS initialization starting.
[0007.53] ScriptLog: WARNING: MASS did not have valid server mode for non-LAN server.  Trying again in 15.0000 seconds.
[0007.53] Log: DEBUG AUTH: Game server has steam game id of "90094389136205827"
[0065.35] ScriptLog: WARNING: MASS did not have valid server mode for non-LAN server.  Trying again in 15.0000 seconds.
[0080.35] ScriptLog: WARNING: MASS did not have valid server mode for non-LAN server.  Trying again in 15.0000 seconds.


The MASS warnings just continue to repeat.

We're a bit stumped because the launcher works but our command line doesn't :/


Top 
 Profile  
 
 Post subject: Re: Auth Issues
 Post Posted: Fri Feb 27, 2015 2:15 am 
Offline

Joined: Fri Feb 20, 2015 12:34 am
Posts: 3
Any help guys :)


Top 
 Profile  
 
 Post subject: Re: Auth Issues
 Post Posted: Fri Feb 27, 2015 7:04 am 
Offline
Volunteer Community Manager
Volunteer Community Manager

Joined: Mon Aug 02, 2004 11:10 am
Posts: 3695
looks like the registration information may not be correct or it's being blocked by a firewall

_________________
Image

Image


Top 
 Profile  
 
 Post subject: Re: Auth Issues
 Post Posted: Tue Mar 03, 2015 4:18 am 
Offline

Joined: Fri Feb 20, 2015 12:34 am
Posts: 3
m_hermann wrote:
looks like the registration information may not be correct or it's being blocked by a firewall


Thanks for the reply :)

The auth info is correct and confirmed, there is no firewall in place.

Launching with the Launcher.exe /ds it works however if I copy/paste the config line I get a registration issue however when I press 'Start' in the Launcher the registration works, with not details needing to be changed. It's as if the launcher is doing something that the command line isn't, even the command line the launcher generates.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 

Board index » America's Army: Proving Grounds » AA:PG Server Support


Who is online

Users browsing this forum: No registered users and 3 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron