America's Army Forums
http://archive2.forum.americasarmy.com/

Lighting problems
http://archive2.forum.americasarmy.com/viewtopic.php?f=50&t=15119
Page 1 of 1

Author:  TheBadaBing! [ Sat Oct 04, 2014 6:37 pm ]
Post subject:  Lighting problems

I am having problems with the light shining through the roof and then through the ceiling onto the floor. It shouldn't do this... Also there is the light shining through the ceiling bit.


Image

Author:  ={KTS}=DELTATHUND3R [ Wed Oct 08, 2014 7:39 am ]
Post subject:  Re: Lighting problems

try adding a bsp plane just above the ceiling assets..
also do you have 1 light mass volume and 1 directional light?

Author:  -=}WoLvErInE{=- [ Wed Oct 08, 2014 12:58 pm ]
Post subject:  Re: Lighting problems

={KTS}=DELTATHUND3R wrote:
try adding a bsp plane just above the ceiling assets..
also do you have 1 light mass volume and 1 Dominate directional light?


Fixed just to be clear. because there is directional light only too. that was the old way of doing lighting. :mrgreen:

Author:  TheBadaBing! [ Wed Oct 08, 2014 6:28 pm ]
Post subject:  Re: Lighting problems

I have a dominate directional light and lightmass setup.

I tried the cutting out a builder brush block above it and it worked for the window light shadow on the walls and floor but that shouldn't be the way to fix it. It didn't sort the light round the roof.

There must be some sort of brush or texture setting that is wrong which is allowing this to shine through?

Author:  ={KTS}=DELTATHUND3R [ Wed Oct 08, 2014 7:14 pm ]
Post subject:  Re: Lighting problems

Where did you get the ceiling asset from..A already developed map or from content browser.Maybe some property values have been changed.
Could you post a image of the adjoining room with windows as well please.

Author:  -=}WoLvErInE{=- [ Wed Oct 08, 2014 8:32 pm ]
Post subject:  Re: Lighting problems

Those look like the inner hospital ceiling trim assets. :-)

Author:  TheBadaBing! [ Tue Nov 18, 2014 10:25 pm ]
Post subject:  Re: Lighting problems

A nameless Dev helped me with the shadow problem. It was a case of deleting the Swarm Cache folder fixed it on the next light build. But no idea why it did it.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/